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Introduction
Overview
DLL Show for Windows 95 is a small freeware utility that displays a list of all tasks and processes currently running on your MS 
Windows 95 system.

DLL Dependencies
Click your mouse on the name of a running process to see a list of all DLL dependencies for that task or process. DLL Show 
can also be used to print a complete list of the selected processes DLL dependencies.

Process Information
Information about all running tasks is displayed in a simple list window. Process information includes the process name, process
ID number, task priority, the number of threads associated with the running process and the physical disk location of the 
executable.

Module Information
Information about each DLL module includes the DLL name, module ID number, the number of process references for the 
currently selected module, the total number of references to the module, the amount of memory used by the module and the 
physical disk location of the DLL module.

Version Information
Version information is also available for all running processes and DLL modules. Simply double-click on the process or DLL 
module displayed in either list to see full version information for the selected item.

Note DLL Show for Windows 95 is designed to work with the Microsoft Windows 95 operating system. It will not work on 
Windows NT operating systems.



Installing DLL Show
Installation
To install DLL Show for Windows 95 on your computer simply create a new, empty folder and place the files; DLLSHOW.EXE 
and DLLSHOW.HLP there.

DLLSHOW.EXE - The DLL Show Application
DLLSHOW.HLP - The Windows 95 Help File

To integrate DLL Show for Windows 95 with the MS Windows Explorer select the DLL Show Setup dialog box while DLL Show 
is running.

Note Settings specified in the DLL Show Options dialog box, as well as the DLL Show    window size and location on the 
desktop, are now saved in the MS Windows 95 System Registry.

Warning If you rename the DLLSHOW.EXE file you must also rename the HLP file using the same basename. For example if 
you change the DLL Show application file name to NewName.exe, rename the help file to NewName.hlp as well. The HLP file 
must reside in the same folder as the application file itself.

Previous Users If you have used a previous version of DLL Show for Windows 95 you can delete the DLLSHOW.INI file 
located in the program folder. This file is no longer used. DLL Show now stores configuration information in the MS Windows 95 
System Registry.



Configuring DLL Show
DLL Show Options
Select the File | Options menu item to display the DLL Show Options dialog box. This window will allow you change the various
DLL Show program settings described below.

Refresh Interval
Specify the refresh rate for updating the task lists. This value can be between 5 and 600 seconds (10 minutes).

Manually Refresh the Task List
Check this item to manually refresh the task list. This will override the task list refresh rate listed above.

Show All Running Tasks
Check this item to display all tasks currently running on the system, these will include programs, DLLs and drivers. If this item
is unchecked only running programs will be displayed in the process list.

Sort the Process List
Check this item to display processes in alphabetical order. If this item is unchecked processes will be displayed in the order 
they occur in the MS Windows 95 task list.

Sort the Module List
Check this item to display modules in alphabetical order. If this item is unchecked modules will be displayed in the order they 
occur in the MS Windows 95 task list.

Show Toolbar Tips
Check this item to display small popup tip windows when the mouse pointer is placed over toolbar ribbon pushbuttons. A 
short description of the button currently beneath the mouse will be shown when this item is checked.

Place Icon in Taskbar Tray
Check this item to display a small DLL Show program icon in the Taskbar Icon Notification Tray. If this item is selected and 
the DLL Show window is minimized a button will not be added to the Taskbar, to restore the DLL Show window on the 
desktop press the small icon in the taskbar tray instead. This item is available to keep the taskbar free for other running 
windows.

Dark Window List Backgrounds
Check this item to display the text in list windows with a dark background instead of the paper white background MS 
Windows normally uses to display text.

Warning Sounds with Dialog Boxes
Check this box to play a short beep sound when DLL Show displays a warning dialog box or an error occurs.

OK
Press this button when you have completed your selection of DLL Show program options. When you press this button the 
DLL Show Options dialog box will be closed and your settings will be saved.

Cancel
Press this button to close the DLL Show Options dialog box without making any changes. If you have made any changes to 
the option settings, and then press this button your changes will not be used, and your previous settings will remain in use.

Default
Press this button to use default DLL Show program options in this dialog box. These will be the same settings that were 
created when DLL Show was run for the first time.

Note The options you have selected will be saved when you press the OK button. The desktop location of the DLL Show 
Options window itself will also be stored. DLL Show setting are saved in the MS Windows 95 System Registry.



DLL Show Explorer Setup
DLL Show Explorer Setup

Select the Help | Setup menu item to display the DLL Show Setup dialog box. This window will allow you to integrate DLL 
Show for Windows 95 with the Microsoft Windows 95 Explorer.

Create a Start Menu Item
Check this item to create a DLL Show Start Menu entry. The DLL Show for Windows 95 program will be located in the 
Software by Design folder on the Programs menu.

Create a Desktop Icon
Check this item to create a DLL Show for Windows 95 program icon on the Explorer desktop.

Create a Startup Folder Item
Check this item to automatically run DLL Show for Windows 95 whenever Microsoft Windows 95 is started. This option 
creates a DLL Show program icon in the MS Windows Explorer Startup folder.



DLL Show Menus
Menu Commands
The DLL Show window displays a set of menus used to select various DLL Show operations. All of DLL Show’s commands are 
carried out using items listed on these menus. To display the commands available click your mouse on the desired menu title. A 
drop down list will be displayed, allowing you to select the command you wish to carry out.

 The File Menu
 The View Menu
 The Help Menu

Note As you move the mouse through the various commands listed on the DLL Show menus a short explanation of what each 
command does will be displayed at the bottom of the main window.

Tip Most commonly used menu commands can be invoked using shortcut keys or buttons on the toolbar ribbon.



File Menu
File Menu Commands
The File menu provides commands to configure and exit DLL Show. A short description of each item follows:

Printer Setup
Use this command to setup the printer to be used for printing module dependency lists.

Printer Font
Use this command to specify the font to be used when printing module dependency lists.

Print
Use this command to print a module dependency list for the currently selected process. This command will be disabled 
(grayed) when DLL Show is configured to automatically update dependency lists. The Ctrl+P shortcut can be used for this 
command.

Note You must disable the automatic update option to print module dependency lists.

Options
Opens the DLL Show Options dialog box and allows you to change DLL Show program settings. Use this command to 
configure the DLL Show program.

Exit
Closes the DLL Show program and returns control to the Explorer desktop. The Ctrl+Q shortcut can be used for this 
command.

Tip Commonly used File commands can be invoked using shortcut keys or buttons on the toolbar ribbon.



View Menu
View Menu Commands
The View menu provides commands used to change the DLL Show display A short description of each item follows:

Properties
Use this command to display module properties for the currently selected process or module. The Alt+Enter shortcut can 
be used for this command. Double-clicking your mouse on an item listed in either the process or module list will also 
display the module properties window.

Refresh
Use this command to refresh the process list. The F5 shortcut can be used for this command.

System Information
Use this command to open the System Information window. This window will display information about your computer 
system’s current hardware configuration and dynamic resource usage.

Error Codes
Use this command to open the Error Codes window. This window will display information about all MS Windows 95 error 
codes and their descriptions.

Minimize
Minimizes the DLL Show window to a button or icon on the taskbar. The Ctrl+Y shortcut can be used for this command.

Always on Top
Use this command to keep the DLL Show window top most on the desktop. When this item is checked the DLL Show 
window will float above all other non-topmost windows on the desktop. This item is useful if you normally run DLL Show 
with a small window that would be easily obscured by other applications. The Ctrl+T shortcut can be used for this 
command.

Tip Commonly used View commands can be invoked using shortcut keys or buttons on the toolbar ribbon.



Help Menu
Help Menu Commands
The Help menu provides commands used to get help for DLL Show operations. A short description of each item follows:

Contents
Opens the DLL Show Help window and displays the Table of Contents. The F1 shortcut can be used for this command.

Search
Opens DLL Show Help and displays the Search window. You can use this window to search for specific DLL Show help 
topics.

How to Use Help
Opens a Help window that explains how to use the MS Windows 95 Help program.

Setup
Displays the DLL Show Setup dialog box. This window provides options to integrate DLL Show with the MS Windows 
Explorer. Use this window to create MS Explorer Start Menu items and desktop icons.

About DLL Show
Displays the DLL Show splash box. This window contains the current version number of DLL Show and a program 
copyright notice. Click the mouse anywhere in this window to close it

Tip Commonly used Help commands can be invoked using shortcut keys or buttons on the toolbar ribbon.



Toolbar Buttons
Tool Ribbon Buttons
Most commonly used DLL Show menu commands can also be quickly invoked by pressing a button on the toolbar ribbon 
displayed at the top of the main window. These buttons work exactly the same way as the corresponding menu items that they 
duplicate.

Properties - Show process properties

Refresh - Refresh the process list

Print - Print module dependency list

Information - Open the resource monitor

Errors - Display the MS Windows Error Codes

Top - Make DLL Show window topmost

Options - Open the DLL Show Options dialog

Help - Open this Help file

About - Show DLL Show splash box

Tip If the Show Tool Bar Tips option was selected a small popup tip window will appear when the mouse pointer is placed over 
a button. A short description of what each button does can be viewed using this method.



Shortcut Keys
Shortcuts
Shortcut keys allow you to quickly invoke menu commands without first displaying the menu and then selecting an item from it. 
The most commonly used DLL Show commands can be invoked using the following shortcut keys.

File Menu
Ctrl+P Print DLL dependencies
Ctrl+Q Exit DLL Show , and return to the desktop

View Menu
Alt+Enter Show properties for current process
F5 Refresh the process list
Ctrl+Y Minimize DLL Show to an icon
Ctrl+T Make DLL Show window topmost

Help Menu
F1 Display this Help file



System Information
System Information
Select the View | System Information menu item to display a small system information and resource monitor window. This 
window is useful for monitoring system resource usage and reporting computer configuration settings.

Activation
To activate the System Information window select the System Information item from the View menu. A small window will be 
displayed on the desktop showing the current system configuration and resource usage.

This window is dynamically updated as system resources change. The following items are reported:

Microsoft Windows
This region displays the version of MS Windows installed on your computer and the type of CPU found. If you are using a 
system that has more than one processor installed this will also be reported here.

Memory
This region displays the total amount of RAM available to Windows as well as the amount of memory that is currently free. MS 
Windows 95 cannot use the lower 640K of memory used by MS DOS so the total RAM available will be slightly less than the 
total RAM installed on your system. The free memory value will change dynamically as programs are loaded, run and unloaded.

Note MS Windows 95 systems use virtual memory, so as physical memory is exhausted virtual memory is created. Watch the
Swap gauge in the Resources section to monitor virtual memory allocation.

Video Monitor
This region displays the current video display resolution and the number of colors available as follows:

1-bit: black & white (monochrome)
4-bit: 16 colors or shades of gray
8-bit: 256 colors or shades of gray
16-bit: Thousands of colors
32-bit: Millions of colors

Resources
This region displays three gauges showing the current resource usage for the System, RAM and Swap space. These items will 
change as programs are loaded, used and unloaded. The color of the gauge changes based upon the current usage as follows:

Blue: less than 90% usage
Yellow: less than 95% used
Red: more than 95% used

Tip If you are having trouble loading a program check these values as you attempt to launch the application.



Error Codes
MS Windows 95/NT Error Codes
Select the View | Error Codes menu item to display a list of all Microsoft Windows 95/NT errors codes and their descriptions.

When this item is selected DLL Show will query the operating system and build a list of all error codes defined for the operating 
system. This list will contain the actual error code numbers as well as a short description of what each error code means. This 
list may be useful if you have other programs that produce error code warnings, but do not include an explanation of what the 
actual error means.

Error codes will be displayed in a list that contains both the decimal error code number as well as the hexadecimal value of the 
error.



Comments and Upgrades
Comments and Suggestions
If you have comments, questions or find any bugs in DLL Show for Windows 95 please feel free to contact me on CompuServe 
or America Online.

Upgrade Notification
If you would like to be notified when this application is upgraded send me an email message with your online address. Please 
include the version number you are using and the location that you downloaded my software from. I will email you when a new 
version of DLL Show for Windows 95 is uploaded to my web site on the Internet, CompuServe, America Online, ExecPC, ZD 
Net, and MSN.

Gregory Braun
CompuServe: 71613,2175
AOL: GreggBraun
Email: 71613.2175@compuserve.com
Web Site: http://www.execpc.com/~sbd
Phone: 1.414.444.8497

Contributions
While DLL Show is offered as Freeware, if you would like to pay for it you are welcome to send any amount you wish to:

Gregory Braun
5609 West Hadley Street
Milwaukee, WI 53210-1554    USA

Your contributions are always welcome, and encourage me to continue developing new applications.

Web Site
Visit my web site on the Internet to download the latest versions of all of my freeware offerings.

Software by Design Web Site

(http://www.execpc.com/~sbd)



Release History
DLL Show for Windows 95 Release History

v2.0 Original in-house development and testing of MS Windows 95 conversion using the Microsoft Win32 SDK.

v2.1 Added Windows 95 splash box for release.

v2.2 Added MS Windows 95 Help file. 

v2.3 Fixed several minor bugs and moved configuration information to the MS Windows 95 System Registry. Fixed a bug that
prevented displaying properties for modules located in folders containing a space in their name.

v2.4 Added setup facilities, MS Windows Error Codes and printing of module dependency lists.

Last Update June 13th, 1997



System Registry
DLL Show for Windows 95 System Registry Key
DLL Show for Windows 95 stores configuration settings in the MS Windows 95 System Registry. These settings are updated 
automatically while DLL Show is running. There is no need to edit these settings manually.

If you insist upon editing these settings, you do so at your own risk. DLL Show automatically updates registry entries when it 
exits. If you wish to edit these settings make sure DLL Show is not running while you edit them. If DLL Show is currently running
your changes will be overwritten when DLL Show exits.

DLL Show for Windows 95 stores configuration settings in the following system registry key:

HKEY_CURRENT_USER
Software

Software by Design
DLL Show for Windows 95

Section
Label = Value

Warning There is no need to edit these settings manually. DLL Show will automatically maintain these settings for you. If you do
edit these, you do so at your own risk.



Software by Design Web Site
Software by Design
You can download the latest versions of all of my freeware from my web site on the Internet. I post the latest releases of my 
software there first. Click your mouse on the link listed below to visit the Software by Design web site.

Software by Design Web Site

(http://www.execpc.com/~sbd)

Freeware Titles
The following software titles are available at my web site on the Internet and can also be found on CompuServe, America 
Online, ExecPC, MSN and ZD Net.

NoteBook for Windows (NBOOK.ZIP)
NoteBook for Windows 95/NT (NBOOK32.ZIP)
Reminders for Windows (REMIND.ZIP)
Reminders for Windows 95/NT (REMIND32.ZIP)
ToolBar for Windows (TBAR.ZIP)
ToolBar for Windows 95/NT (TBAR32.ZIP)
Screen Loupe for Windows (LOUPE.ZIP)
Screen Loupe for Windows 95/NT (LOUPE32.ZIP)
Screen Loupe for Macintosh (LOUPE.SEA)
Audition for Windows 95/NT (AUDITION.ZIP)
Password Keeper for Windows 95/NT (PASSKEEP.ZIP)
CardBase for Windows 95/NT (CARDBASE.ZIP)
File Editor for Windows (FXEDIT.ZIP)
File Editor for Windows 95/NT (FXEDIT32.ZIP)
Quiz Wizard for Windows 95/NT (QUIZWIZ.ZIP)
Crypto for Windows 95/NT (CRYPTO.ZIP)
Icon Extractor for Windows (ICONX.ZIP)
Icon Extractor for Windows 95/NT (ICONX32.ZIP)
DLL Show for Windows 95 (DLLSHOW.ZIP)
TxEdit for Windows 95/NT (TXEDIT.ZIP)
RGB Editor for Windows (RGB.ZIP)
RGB Editor for Windows 95/NT (RGB32.ZIP)
FontShow for Windows 95/NT (FONTSHOW.ZIP)
Programmer's IDE (PMAN.ZIP)
Programmer's IDE 95/NT (PMAN32.ZIP)
Touch for Windows (WTOUCH.ZIP)
Disk CleanUp for Windows 95/NT (CLEANUP.ZIP)
BattleStar for Windows (BSTAR.ZIP)
BattleStar for Windows 95/NT (BSTAR32.ZIP)
World Radio for Macintosh (WRADIO.SEA)

Note The latest versions of my software programs are always posted on my web site first. Versions found on the other online 
services may be earlier releases.



BBS and Internet Operators
Webmasters
Please upload the original ZIP file intact and title the submission:

"DLL Show for Windows 95 v2.4"
--Author Gregory Braun

Web Site
Visit my web site on the Internet to download the latest versions of all of my freeware offerings.

Software by Design Web Site

(http://www.execpc.com/~sbd)

Note This site also supports anonymous FTP transfers.






